Back to overview
Downtime
Cloudflare is down, affecting services.
Dec 05 at 07:39pm ACDT
Affected services
Superposition Testnet Explorer/Bridge
Superposition Testnet RPC
Superposition Faucet
Superposition faucet is processing requests
Resolved
Dec 06 at 01:00am ACDT
Everything is resolved! Thanks for your patience.
Affected services
Created
Dec 05 at 07:39pm ACDT
Cloudflare is having a systems outage that's affecting us. The team is working on mitigations.
Affected services